Back to overview
Downtime
We do not know why the panel and billing Panel are down more about it soon
Jan 09, 2025 at 02:44pm UTC
Affected services
Ping KermitCloud Main
TMS Mod Bot Heartbeat
Resolved
Jan 09, 2025 at 03:11pm UTC
Host And Servers Are Back Up
Affected services
Created
Jan 09, 2025 at 02:44pm UTC
We do not know why the panel and billing Panel are down more about it soon if you need support join the discord or email support@kermitcloud.space
Affected services